Change autoloader unload speed

Hi all,

I have a 300mL trough on a carrier with about 150mL water. I am able to change the speed at which the autoloader loads the carrier (slowly) by changing the MlStarBarcodeReadSpeed, but during unload the autoloader goes at default speed (fast!). The water sloshes around in the trough during unload.

Does anyone know how to have the autoloader unload a carrier slowly?

Thanks!

This can certainly be done, but I’d like to test it myself before providing a solution to ensure it is streamlined. I can follow up with a solution in the next business day or so.

In the meantime, if the protocol allows for it, you can circumvent the issue by disabling the unload step and loading the carrier(s) on the load tray at the carrier stop hook instead of loading on deck.

I take it this is STAR-line, correct?

Thanks.

-Nick

(assuming Microlab STARLet Hamilton)

You are using smart or single step functions? Usually single steps has more freedom.

You can try ML_STAR → Single Steps → Preparation → Unload Carrier (Single Step). If the function is not there, you can enabled it here: Tools > System Configuration Editor → Microlab STARLet → Commands

image

Yes, I am using single steps. I don’t see a way to change the unload speed.

1 Like

Hi Nick,

Yes, its a STAR-line instrument.

Haven’t tried this with the Unload Carrier command, but you can try firmware command “I0AA” with parameter “yv####”. The default for #### is 2000 so could try something like “yv0500” to slow it down. Then run it again after the unload command with parameter “yv2000” to set it back to default.

Edit:
Password for the linked folder is Hamilton24

Linked here is a function I wrote to control the unload speed of an unload single step. The usage is straight forward, acting essentially similar to the single step with an additional speed parameter:

This has been tested on system to confirm performance. If you wish to toggle the error behaviors of the step, then open the function and toggle the embedded ‘Unload’ single step error settings as normal (method editor line 33).

Note that the default speed is 128.1mm/s, so setting all the way down to ~10mm/s will likely appear painfully slow, unless your intention is to play a prank on one of your colleagues.

Hope this helps!

-Nick

5 Likes

Sweet, thank you. I’ll give it a whirl.

3 Likes