Error: USB device is already configured


For context, I was running a protocol that worked perfectly fine. After the protocol was done, I tried to run it again (for another sample) but this error popped up instead. Anyone has any idea of how to resolve this error? Any help is much appreciated.


Issue has been resolved by another colleague. What I had to do was restart the monitor, then turn off the instrument. Once the desktop loaded, the machine was turned back on. Leaving this forum here in case someone runs into this issue.

Hi @Nat,

I’m glad to hear you got the issue resolved. Here is some additional information for the future:

  1. This error occurs when the Run Control is already connected to the instrument, then Run Control is opened again and tries to reconnect. As the USB is already being used, it can’t connect twice so this error window pops up.

  2. In some instances the Run Control window will close, but the application remains open and connected to the instrument in the background. Power-cycling the instrument like you did will sometimes resolve this, but another option is to use the Task Manager to manually close the hidden instance of Run Control. The Run Control will usually be seen under the Processes tab as its own App, but sometimes can be found under the Method Editor App if Run Control was opened from the Method Editor.


Thank you,