Hepa Hood Error


We are receiving this error message in regards to our HEPA hood: Instrumennt Error: Couldn’t setup the fan controller communications. Error Code: 0x52 - 0x1 - 0x8001 when we try to run one of our methods. We have tried to go into the Device Manager, on the computer and change the advanced settings in the specified com port, because we know that the Com Port for the hood should be mapped to the “Isolated RS-485 Port”. When we are in the advanced settings we have the RS-485 option but it also has a drop down menu containing 4 other options: Full DUPLEX, Full DUPLEX TXEN AO, Half Duplex, and Half Duplex Echo. I have gone through all four of those options with the RS-485 setting and still we are running into the same error message.

We did ensure that the HEPA hood is plugged in, and is turned on, and we can hear the click of the hood when we flip the power switch… Any thoughts?

Have there been any updates to the computer recently?

My recommendation is to unplug the HEPA USB, restart the computer, plug it in again, and check the Device Manager to confirm the RS-485 port is present and there is an assigned COM. If it all looks good there (as shown below) and you are still seeing an issue, I recommend reaching out to your local support to further troubleshoot.

Thank you for the response, yes there were some updates to the computer when the PM was done, which caused for some of our configurations to be off, so we had an application specialist come in and fix the errors that we had from that. So unfortunately I am assuming that this also had some effect on the com ports. I tried following the unplugging, restart and plugging back in and that did not change any of the com ports.

We have also gone ahead and have reached out to our FAS as well as posting here.

1 Like

Just to follow up on this thread. My teammate and I were able to fix this issue!

When looking back at the device manager we noticed that there was an unknown device that would pop up above the ports list. To confirm our hunch we un-plugged and plugged back in the Hepa Hood USB, which would cause that unknown device to disappear and reappear. After that we went ahead and uninstalled the HEPA library and the USB driver. Then went ahead and reinstalled both, restarted the computer and went back into the device manager to see that the correct RS-485 Isolated Port was now in our ports list.

To confirm that the HEPA hood was working, we went ahead and opened our script, changed the port number to the specified one in the ports list and ran the script. The fan successfully connected and turned on!


My device manager seems to have issue with the Port of HEPA filter. It is not shown as RS-485, instead is displayed “Model USOPTL4”. I have tried to install different driver versions, but none have worked. Also, in the method editor software I have encountered another error in printscreen below.

Which version of VENUS are you running? I assume this is Windows10?

I suspect you are using an out of date/incompatible driver. Check the materials share for the most recent version of the HEPA fan driver. This will install a device HSL library, and does not connect as a deck device that you add as an instrument to a deck layout. This was modified as the older-style deck-instrument driver is not compatible with Windows 10.

You will want to uninstall any previous HEPA drivers you installed in previous attempts.

The linked driver will also install with it the required USB driver for PC connection and communication, which should resolve the issue the device manager issue.


Thank you Nick! I am using Windows 11 Pro and it worked with this latest version (Hamilton Hx Fan v1.0 (6603874-01). Is there any tutorials or demo methods on how to use the HEPA library?


Here’s a Hepa test method I drafted a while back. Hope it helps!

FYI, VENUS four is only validated for use with Windows 10. Glad you have it working on 11, but know that we can’t guarantee performance - we’ve seen it work on some setups and not on others. The next version of VENUS will be Windows 10 and 11 compatible.