Vector Database connection issue

Does anyone else ever get problems with methods failing to start at the following step?

I’ve tried restarting, all the usual stuff, but sporadically get this… weird!

@Gareth - Can you please share the entire contents of the run trace file?



The first thing I would try would be re-preparing the Vector database server. Sometimes this will clear SQL server related issues on installations that have been active for some time.

If you are using an administrator level account, you should be able to use a trusted connection.

Hopefully this resolves it.


1 Like

Thanks Nick! I didn’t know about the Prepare Server button - I’ll try that next time I have problems. If that doesn’t work I’ll put the full logs here.

Just for info, what’s the normal password that’s used for the login settings in your screenshot? The box above the Prepare server button…

Hi Gareth,

Check page 40 of the VENUS programmer’s manual, it contains the default HAMILTON SQL user account login credentials that install with VENUS (used when run control needs to connect to the Vector database at the onset of runs for SQL server authentication).

When VENUS installs SQL server and creates the Vector database instance, it sets up a default (Hamilton) SQL user account to be used for database connections. This account is automatically set up with permissions and server roles that allow for robust connection to SQL server, regardless of the user permissions for whoever is logged into Windows. By default, the login settings will be set to not use a trusted connection, and to use this account when connecting to the database.

If it is set for ‘trusted connection’ then the credentials of the current user will be used. If the user does not have appropriate permissions, this can lead to connection failures and other issues.

Using SQL server management studio, you can reset the password for the Hamilton account if it is desired to not use the default password. Sometimes there are local IT policies that enforce password rules that the default doesn’t meet, but this is rather uncommon.